Text MFP Website Issue
Incident Report for Studio MFP
Resolved
Text MFP’s server has been updated and functionality is at 100%.
Posted Sep 15, 2019 - 09:26 EDT
Identified
We’ve identified an issue with our server and are implementing an update. Please bare with us. All services will still function, but you may not be able to log in.
Posted Sep 15, 2019 - 09:08 EDT
This incident affected: Text MFP App (Text MFP Website).