Agency App Server Upgrade
Incident Report for Studio MFP
Resolved
Our Agency App is back up and running. Server upgrades include cloud storage max file size of 5G, and other performance improvements.
Posted 3 months ago. Feb 13, 2019 - 05:00 UTC
Update
We are continuing to monitor for any further issues.
Posted 3 months ago. Feb 13, 2019 - 03:00 UTC
Monitoring
Our Agency App is upgrading its server, please be patient while we conduct necessary maintenance.
Posted 3 months ago. Feb 13, 2019 - 02:59 UTC
This incident affected: Agency App.