Our sales phone line is currently experiencing disruptions.
Incident Report for Studio MFP
Resolved
This incident has been resolved.
Posted Mar 26, 2020 - 18:58 EDT
Update
We are continuing to work on the phone issue. Our team is available via chat, email, or direct extension.
Posted Mar 25, 2020 - 16:53 EDT
Identified
Our phone lines are currently down. We are working on a fix to our phone system. Please email us at contact@studiomfp.com or support@studiomfp.com during this time of unexpected high volume. Our hosting phone support is still operational.
Posted Mar 23, 2020 - 11:36 EDT
This incident affected: Studio MFP Website.